Non è ansible disporre di privilegi in CMD quando si è connessi come amministratore

Stavo cercando di usare il command mklink in cmd (ho Windows 7 os) Sono stato connesso come amministratore, ma ho ottenuto un messaggio "non hai il privilegio sufficiente per eseguire questa operazione". Ho usato lo stesso command in Vista, ha funzionato bene. Qualche idea di perché non funziona in Winows 7?

Provare a eseguire esplicitamente la shell cmd come amministratore . Se ciò non aiuta, prova il command runas .

runas /user:administrator "mklink args" 

Sono richieste le citazioni attorno al command mklink e ai suoi args.

digitare CMD, vednetworking CMD.exe nell'elenco al menu di avvio.

Fare clic con il tasto destro su di esso, select "Esegui come amministratore"

In risposta a questo non funziona per gli account di amministratore, credo che la configuration del supporto di symlink in Win7 sia rilevante.

Dopo aver dato "Everyone" il privilegio "Crea collegamento simbolico", riavviate (o disconnettenetworking) e accedete come utente standard, un utente che NON è membro del gruppo "Amministratori". Dovresti essere in grado di creare un collegamento simbolico utilizzando il command mklink in una directory in cui gli utenti dispongono di autorizzazioni di scrittura.

Il motivo per cui un membro di "Amministratori" non è in grado di creare un collegamento simbolico è che il privilegio "Crea collegamento simbolico" viene rimosso dal token filtrato poiché l'utente è membro del gruppo "Amministratori". La sezione "Change Token di accesso" dell'articolo all'indirizzo http://msdn.microsoft.com/en-us/library/bb530410.aspx descrive in dettaglio il modo in cui viene creato il token filtrato.

Innanzitutto, assicurati di aver concesso l'authorization "Crea collegamenti" agli utenti rilevanti, come qui indicato: https://superuser.com/a/125981/57697

Bizarre, il command "mklink" non functionrà per me se il mio utente è un amministratore. Dà "Non hai sufficienti privilegi per eseguire questa operazione".

Per farlo funzionare, devo quindi rimuovere il mio utente dal gruppo di amministratori oppure eseguire mklink da un cmd che è stato eseguito come utente non amministratore come guest:

  runas /user:guest cmd 

(abilita l'account guest se non lo è già)

Utilizzando questo ultimo metodo, dovrai anche concedere temporaneamente le autorizzazioni per 'ospite' per modificare la posizione in cui stai creando il simbolo, che nel mio caso era la mia home directory, provocando un stream di dialoghi di errore, ma sembravano innocui .

Controllare che il servizio "accesso secondario" non sia disabilitato.

Se non è installato, si prega di installare Microsoft.net framework 2.0 oi service pack che vanno con esso. Ha funzionato per me!