Perché l'ospite di Windows 8 Pro Hyper-V non dispone di internet?

Cercando di get questo lavoro sulla mia macchina Windows 8 Pro. Ho creato un interruttore esterno

Assegnato l'adattatore appena disponibile ad una macchina Guest con Win 2008 os. Il mio host ha connessione internet. L'ospite può ping Guest, Guest non può ping Host.

L'ospite non ha connessione a internet. Incollare l'IP sia dell'ospite che dell'ospite.

HOST ========================== Ethernet adapter vEthernet (EXTSW01): Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2 Physical Address. . . . . . . . . : 9C-B7-0F-0F-D7-D0 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::5434:a9fd:8611:d207%54(Preferred) IPv4 Address. . . . . . . . . . . : 192.168.0.15(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : Saturday, September 8, 2012 12:34:44 PM Lease Expires . . . . . . . . . . : Saturday, September 15, 2012 12:34:44 PM Default Gateway . . . . . . . . . : 192.168.0.1 DHCP Server . . . . . . . . . . . : 192.168.0.1 DHCPv6 IAID . . . . . . . . . . . : 916240141 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-DC-C9-2C-9C-B7-0D-0D-D7-D0 DNS Servers . . . . . . . . . . . : 64.71.255.999 NetBIOS over Tcpip. . . . . . . . : Enabled 

 GUEST ========================== Ethernet adapter Local Area Connection: Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Microsoft Virtual Machine Bus Network Adapter Physical Address. . . . . . . . . : 00-15-5D-3F-0F-00 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::953f:ec5c:5d84:1b50%11(Preferred) IPv4 Address. . . . . . . . . . . : 192.168.0.20(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : 0.0.0.0 DHCPv6 IAID . . . . . . . . . . . : 234886493 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-DD-2F-29-0F-15-5E-00-0F-00 DNS Servers . . . . . . . . . . . : ::1 127.0.0.1 NetBIOS over Tcpip. . . . . . . . : Enabled 

Ho avuto problemi simili a questo. Sembrava essere causato dall'installazione di altri software di virtualizzazione (Virtualbox) insieme a Hyper-V. È ansible controllare le properties; -> scheda di condivisione della scheda vEthernet e provare ad impostarla per condividere internet. Ho ancora problemi di Internet intermittenti con questa installazione però.

Ho finito per disinstallare Virtualbox per get Hyper-V solido.

Modifica: https://forums.virtualbox.org/viewtopic.php?f=6&t=48044

Non dimenticare di triggersre l'ID LAN virtuale che puoi trovare nelle impostazioni Guest del Hyper-V-Manager!

immettere qui la descrizione dell'immagine