Supporto Firefox non supportto

Esiste un firefox addon che non è supportto dall'ultima versione installata nel mio computer. So che c'è un modo per usarlo modificando il file xpi, ma non riesco neanche a scaricare i file xpi dal sito mozilla addon (il button "get addon" è distriggersto)

Qualcuno può aiutarmi qui?

Modifica: questo ad esempio – https://addons.mozilla.org/en-US/firefox/addon/5462

Utilizzo gli strumenti Nightly Tester, invece di modificare il file XPI: https://addons.mozilla.org/en-US/firefox/addon/6543?src=api

Ciò consente di contrassegnare un addon come compatibile (qualcosa di simile), che è abbastanza una necessità per i tester di build di notte. Dovresti usare con caucanvas, naturalmente.

Provi a scorrere verso il basso la pagina addon in basso, c'è un collegamento denominato "versioni precedenti". Se fai clic su questo link sarai portto a una pagina che ti permette di scaricare tutte le versioni più le ultime.

È ansible impostare semplicemente il valore di extensions.checkCompatibility su false (si tratta di una preferenza di: config ).

Qualcuno ha inviato un link alla versione 0.2.0 nei commenti per l'addon … Bosskey

http://ftp.mozest.com/addons/extensions/boss_key/boss_key-0.2.0-fx+fl+ns+tb-windows.xpi 

Lo ho fatto prima. Ha il potenziale di rompere le cose se l'addon non è effettivamente compatibile, ma funziona bene un sacco di tempo.

  1. Scarica e installa 7zip
  2. Fare clic con il button destro del mouse sul file .xpi e scegliere 7zip-> aprire l'archivio
  3. Fare clic con il button destro del mouse su install.rdf e scegliere la modifica
  4. Trova questo codice: <!-- firefox --> <em:minVersion>1.5</em:minVersion> <em:maxVersion>3.*</em:maxVersion>
  5. Modificare la versione massima per le tue esigenze
  6. Salvare il file. Dovrebbe essere aggiornato automaticamente all'interno dell'archivio.
  7. Chiudere il block note e 7zip. Apri il file xpi nel firefox. Speriamo che installeremo!

Una sintesi delle risposte, con un po 'di più:

Innanzitutto è necessario impostare il firefox per accettare l'estensione "obsoleta": utilizzare i più semplici strumenti Nightly tester ( credito MetalMikester ) o il toolkit MR Tech con funzioni estese (mi piace il button a discesa delle estensioni e altri) ( credito: harrymc ). Oppure, come hai detto, puoi modificare manualmente il file xpi ( credito: nhinkle ) ma è più fastidioso

Avanti (e più specifico alla tua domanda) devi evitare la protezione del sito: usa la versione "vecchia" nella parte inferiore della pagina ( credito: CGA ) o crea un acount mozilla , avrai un link "ignorare la verifica della versione" nel button (credito me)

Colpisci il collegamento All Versions in fondo. Seleziona la casella per installare il componente aggiuntivo sperimentale. Il button Aggiungi a Firefox dovrebbe passare da grigio a verde. Ora fare clic con il button destro del mouse sul button e scegliere Salva collegamento come. Ora è ansible eseguire il hack per lavorare con la tua versione se necessario e quindi trascinare l'aggiornamento XPI nella tua casella di componenti aggiuntivi nella sezione Estensioni.

Adesso è un modo migliore per farlo: utilizza il Reporter di compatibilità di componenti aggiuntivi , un'estensione sviluppata da Mozilla. Oltre a consentire l'esecuzione di qualsiasi estensione, ti consente di dare un feedback se funziona o no.

Reporter di compatibilità di componenti aggiuntivi

Aiuta Mozilla a assicurarsi che i tuoi add-on preferiti siano aggiornati per le prossime versioni di Firefox utilizzando questa estensione per segnalare se funzionano ancora o che hanno alcuni problemi con le versioni beta e beta.

Il molto utile add-on MR Tech Toolkit :

Fornisce gli strumenti necessari per installare e gestire estensioni e themes localmente e tonnellate di altre funzionalità.

Questa estensione fornisce un supporto di installazione multi-interno, funzionalità di hacking alle windows Gestione estensioni / themes, funzionalità per individuare e risolvere i problemi relativi alle informazioni Extension / Themes Build, GUID e Profile.

Immagine